最近在测试不同的拥塞控制算法对于网络的提升,由于 BBR 需要安装在内核大于 4.9 的版本上,所以会经常性的更换内核,以下为更换内核的方法。
如何更换
  • 查看可以安装的内核
apt-cache search linux
  • 查看当前内核
dpkg --list | grep linux-image
  • 显示已安装的内核
dpkg --list | grep linux-image
  • 设置内核版本
version=4.11.0-14
  • 安装内核
sudo apt-get install -y linux-headers-$version-generic linux-image-$version-generic linux-image-extra-$version-generic
  • 卸载内核
apt autoremove
apt-get purge linux-{header or images}-{version}